Zranitelnosti a opravy: Cisco, Dell i LG

Pavel Houser , 15. duben 2015 09:00 0 komentářů
Rubriky: Security
Zranitelnosti a opravy: Cisco, Dell i LG

Bezpečnostní aktualizace pro systémy Apple. Plug-iny pro WordPress jsou chronickým problémem. Totéž platí pro domácí směrovače i anonymizační systémy. Zneužitelné chyby ovšem obsahuje i běžný software respektovaných výrobců, takže ohrozit se lze i při hledání ovladačů nebo nastavování monitoru.

Nový Firefox

Mozilla vydala opravu Firefoxu. Nedávno uvolněná verze 31 obsahovala chybu v implementaci šifrování přes protokol HTTP/2 Alternative Services. Důsledkem mohly být podvody se SSL certifikáty (útočník se mohl vydávat za jiný server) a útoky man-in-the-middle. Pokusy o zneužití zaznamenány nebyly, i tak se ale doporučuje aktualizaci neodkládat. Zalátaná verze Firefoxu má číslo 37.0.1, Mozilla ovšem celou záležitost dále zkoumá a chystá se systematičtější řešení problému.

Opravy pro Mac OS X a iOS

Chyba CVE-2015-1130 v systémech Mac OS X umožňuje zvýšení uživatelských oprávnění. Libovolný uživatel může díky tomu získat práva roota. Výhodné je to např. pro útočníky, kteří dokáží při webovém útoku ovládnout účet aktuálně přihlášeného uživatele. Apple vydal záplatu zranitelnosti, ovšem pouze pro verzi OS X 10.10.x.

Švédský hacker Emil Kvarnhammar uvedl, že chyba víceméně spočívá v nepublikovaném rozhraní API, a proto ji označuje za backdoor výrobce. Všem uživatelům Mac OS doporučuje Kvarnhammar v této souvislosti rychlou migraci na OS X Yosemite 10.10.3. Zvýšení uživatelských práv/zneužití má být velmi snadné. Apple současně se zmíněnou opravou vydal i další záplaty pro Mac OS X, iOS a Safari.

Objevena byla zranitelnost v open-source komponentě Darwin, která je součástí OS X a iOS. Zranitelnost označená jako „Darwinova atomovka“ (Darwin Nuke) vystavuje zařízení s OS X 10.10 a iOS 8 nebezpečí vzdáleně aktivovanému útoku DoS. Ten může zařízení uživatelů poškodit a mít dopad i na podnikovou síť, k níž je připojeno. Nejnovější verze OS X 10.10.3 nebo iOS 8.3 jsou již opraveny. Zdroj: Tisková zpráva společnosti Kaspersky Lab

Zase ten WordPress Další zranitelnost v plug-inu pro WordPress, tentokrát je problém s WP-Super-Cache. Chyba umožňuje útočníkům přes SQL injection nahrát do kódu serveru svůj vlastní kód a zkoušet pak instalovat maware návštěvníkům kompromitovaného webu. Alexandre Montpas ze společnosti Sucuri uvádí, že problém se týká více než milionu webů. Opravená verze plug-inu má číslo 1.4.4. Zajímavé je, že k aktualizaci WordPressu a plug-inů správce webů přímo vyzvala i FBI (!). Varování uvádí, že na chybu by se mohli zaměřit útočníci hlásící se k Islámskému státu (nemusí jít přímo o jeho „příslušníky“, spíše sympatizanty), kteří prý mají právě zranitelnosti WordPressu ve speciální oblibě. Viz také předešlý Bezpečnostní přehled

Google oznámil, že vyvinul šifrování tabulek pro databázi MariaDB, což je klon (fork) MySQL, který vznikl po koupi Sunu Oraclem. Šifrování v MariaDB Server 10.1 a MariaDB Enterprise Server by mělo chránit především před útoky SQL injection.

Spor o automatizované aktualizace

F-Secure uvádí, že v nástroji Dell System Detect (slouží především pro vyhledávání potřebných ovladačů) je chyba, která brání jeho automatické aktualizaci; ve skutečnost je třeba navštívit web Dellu a mít přitom současně spuštěný program. V důsledku toho provozuje většina (v rámci studovaného vzorku prý až 99 %) uživatelů starší a zranitelné verze tohoto softwaru. Nejnovější verze má číslo 6.0.14.

Dell problém, nebo alespoň jeho závažnost popírá. F-Secure ale považuje záležitost za hodně vážnou, protože starší verze Dell System Detect umožňují úspěšný útok už při návštěvě podvodného webu, není přitom potřeba nic dalšího (zranitelnosti Java, Flash, samotný prohlížeč apod.).

Běžný software vypíná ochranu Windows Software pro nastavování monitorů od LG prý v tichosti vypíná Řízení uživatelských účtů (UAC) ve Windows. Zřejmě je cílem hladší uživatelská zkušenost, ale UAC je od Windows Vista důležitým bezpečnostním prvkem; i při práci s právy administrátora je totiž určité změny v počítači při instalaci a spouštění programů stále třeba odklikat ručně. Na problém upozornil německý vývojář Christopher Bachner. Uvádí, že od společnosti velikost LG by tak neprofesionální chování nečekal. Řízení uživatelských účtů je na postiženém počítači třeba znovu nastavit ručně a před tím je navíc nutno i odinstalovat software LG.

Opraveny byly dvě zranitelnosti v protokolu Network Time Protocol (NTP), který se používá pro synchronizaci času mezi systémy v síti. Chyby lze zneužít k útoku na dostupnost služeb a akcím typu man-in-the-middle s podvržením paketů, které budou zpracovávány, jako by měly platný MAC (message authentication code). Opravená verze démona pro NTP má číslo ntpd-4.2.8p2.

Cisco vydalo opravy zranitelností v produktech Cisco Adaptive Security Appliance (ASA). Chyby umožňovaly útoky na dostupnost služby, vsunutí příkazů nebo zahlcení paměti. Za nejzávažnější se pokládá díra CVE-2015 – 0675, které útočníkovi dovoluje vzdálené ovládnutí postiženého zařízení. Doporučuje se samozřejmě rychlá aktualizace, i když Cisco dodává, že pokusy o zneužití zatím zaznamenány nebyly.

Pokročilé funkce směrovačů raději vypínat Směrovače Belkin jsou zranitelné způsobem, který byl v minulosti objeven u produktů D-Link. V zásadě má jít o generování hesel předvídatelným způsobem při vytváření Wi-Fi sítě či přidávání nových zařízení. Použito je přitom sériové číslo zařízení a jeho adresa MAC. Tyto údaje může útočník zjistit zasláním paketu na cílené zařízení, příslušné údaje budou (v otevřené podobě) obsaženy v odpovědi.

Problém se nejspíš bude týkat i celé řady dalších výrobců především domácích směrovačů. Jako jedna z možností ochrany se doporučuje vypnout funkci Wi-Fi Protected Setup. O problémech směrovačů viz také: Zero day chyby na každém kroku

Opravy anonymizačního systému Tor látají bezpečnostní chyby zneužitelné především pro shození služeb. Nejnovější verze mají čísla 0.2.5.12 a 0.2.6.7, v tuto chvíli by opravy již měly být implementovány i do vydání stabilní verze.

CSIRT.CZ varuje

Pierluigi Paganini ze společnosti Bit4Id upozornil na kritickou chybu v programu BitTorrent Sync, kterou lze zneužít ke vzdálenému spuštění kódu. Záplata je již k dispozici.

Ricardo Narvaja ze společnosti Core Security zjistil, že zranitelnost v softwaru Vampset (nástroj pro práci s ochrannými relé) od Schneider Electric umožňuje spustit libovolný kód. Chybu nelze zneužít vzdáleně. Opravená verze má číslo 2.2.168. Zdroj: Národní centrum kybernetické bezpečnosti


Komentáře

RSS 

Komentujeme

Další na řadě je bezpečnost

Richard Jan Voigts , 09. říjen 2017 00:00
Richard Jan Voigts

Co všechno lze automatizovat pomocí strojového učení? Larry Ellison, technologický ředitel společnos...

Více







RSS 

Zprávičky

Bělobrádek chce evropská pravidla pro internetová média

ČTK , 17. říjen 2017 00:55

Podle expertů na internetová média jde o předvolební proklamaci. ...

Více 0 komentářů

Mobilní signál bude i v tunelech pražského metra

ČTK , 16. říjen 2017 15:19

V první fázi by měl být signál na trase metra C mezi stanicemi Muzeum a Roztyly....

Více 0 komentářů

Další velká pokuta pro Qualcomm, tentokrát na Tchaj-wanu

ČTK , 16. říjen 2017 13:10

Qualcomm čelí vyšetřování také v Evropské unii....

Více 0 komentářů

Starší zprávičky

Vybudování infrastruktury na vysokorychlostní internet bude stát 120 až 150 miliard Kč

Pavel Houser , 16. říjen 2017 08:00

Firmy na jednání Hospodářské komory potvrdily, že mají zájem čerpat prostředky na výstavbu vysokoryc...

Více 0 komentářů

Qualcomm se žalobou snaží zakázat prodej iPhonů v Číně

ČTK , 14. říjen 2017 08:00

Obě firmy vedou právní spory kvůli licencím technologií firmy Qualcomm již měsíce....

Více 0 komentářů

Nové profese: manažer spolupráce a specialista sdílení technologií

Pavel Houser , 13. říjen 2017 13:35

Umělá inteligence mění trh práce. Zavádění robotické automatizace dává vzniknout zcela novým profesí...

Více 0 komentářů

Šéf Samsungu překvapivě oznámil rezignaci

ČTK , 13. říjen 2017 13:06

Firma současně informovala, že čeká rekordní zisk....

Více 0 komentářů